Update dependencies

Nina requested to merge upgrade-nokogiri into master

Capybara >= 3.16 requires ruby 2.4. I pinned it to 3.15 for now, so that ruby 2.3 still works.

This also includes an upgrade of the nokogiri version to fix the following vulnerability:

Name: nokogiri
Version: 1.10.1
Advisory: CVE-2019-11068
Criticality: Unknown
URL: https://github.com/sparklemotion/nokogiri/issues/1892
Title: Nokogiri gem, via libxslt, is affected by improper access control vulnerability
Edited by Nina

Merge request reports