Commit 8bc924af authored by Nina's avatar Nina
Browse files

Merge branch 'gemspec-sort-deps-alphabetically' into 'main'

gemspec: sort dependencies alphabetically

See merge request !380
parents 707369be d12166c5
Pipeline #59815 passed with stage
in 4 minutes and 21 seconds
......@@ -25,29 +25,29 @@ Gem::Specification.new do |s|
'mailing_list_uri' => 'https://lists.nadir.org/mailman/listinfo/schleuder-announce/',
}
s.required_ruby_version = '>= 2.5.0'
s.add_runtime_dependency 'mail', '~> 2.7.1'
s.add_runtime_dependency 'mail-gpg', '~> 0.3'
s.add_runtime_dependency 'activerecord', '~> 6.1.3'
s.add_runtime_dependency 'bcrypt', '~> 3.1.2'
s.add_runtime_dependency 'charlock_holmes', '~> 0.7.6'
s.add_runtime_dependency 'gpgme', '~> 2.0', '>= 2.0.19' # Explicitly include to force a version.
s.add_runtime_dependency 'mail', '~> 2.7.1'
s.add_runtime_dependency 'mail-gpg', '~> 0.3'
s.add_runtime_dependency 'rake', '>= 10.5.0'
s.add_runtime_dependency 'sqlite3', '~> 1.4.2'
s.add_runtime_dependency 'sinatra', '~> 2'
s.add_runtime_dependency 'sinatra-contrib', '~> 2'
s.add_runtime_dependency 'thor', '~> 0'
s.add_runtime_dependency 'sqlite3', '~> 1.4.2'
s.add_runtime_dependency 'thin', '~> 1'
s.add_runtime_dependency 'charlock_holmes', '~> 0.7.6'
s.add_development_dependency 'rspec', '~> 3'
s.add_development_dependency 'hirb', '~> 0'
s.add_development_dependency 'factory_bot', '~> 6.0'
s.add_development_dependency 'database_cleaner', '~> 2.0'
s.add_development_dependency 'simplecov-console', '~> 0'
s.add_development_dependency 'rack-test', '~> 1'
s.add_development_dependency 'rubocop', '~> 1'
s.add_runtime_dependency 'thor', '~> 0'
s.add_development_dependency 'byebug', '~> 10'
s.add_runtime_dependency 'gpgme', '~> 2.0', '>= 2.0.19' # Explicitly include to force a version.
s.add_development_dependency 'database_cleaner', '~> 2.0'
s.add_development_dependency 'factory_bot', '~> 6.0'
s.add_development_dependency 'hirb', '~> 0'
if Gem::Version.new(RUBY_VERSION) >= Gem::Version.new('2.6.0')
s.add_development_dependency 'irb'
end
s.add_development_dependency 'rack-test', '~> 1'
s.add_development_dependency 'rspec', '~> 3'
s.add_development_dependency 'rubocop', '~> 1'
s.add_development_dependency 'simplecov-console', '~> 0'
s.post_install_message = "
Please consider additionally installing schleuder-cli (allows to
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment