Verified Commit 8a116b7b authored by Nina's avatar Nina

Delete gemspec and move dependencies to Gemfile

Providing a rails app as a gem is not really possible
parent cf809c9b
source 'https://rubygems.org'
gemspec
gem 'rails', '~> 4.2'
gem 'bcrypt', '~> 3.1'
gem 'activeresource', '~> 4.0'
gem 'haml-rails', '~> 0.9'
gem 'sass-rails', '~> 5.0'
gem 'bootstrap-sass', '~> 3.3'
gem 'simple_form', '~> 3.2'
gem 'squire', '~> 1.3'
gem 'cancancan', '~> 1.9'
# Include some fixes
#gem 'activeresource', require: 'active_resource', github: 'rails/activeresource', ref: 'd6a5186'
......
PATH
remote: .
specs:
schleuder-web (3.0.0.beta1)
activeresource (~> 4.0)
bcrypt (~> 3.1)
bootstrap-sass (~> 3.3)
cancancan (~> 1.9)
haml-rails (~> 0.9)
rails (~> 4.2)
sass-rails (~> 5.0)
simple_form (~> 3.2)
squire (~> 1.3)
GEM
remote: https://rubygems.org/
specs:
......@@ -56,23 +42,22 @@ GEM
minitest (~> 5.1)
thread_safe (~> 0.3, >= 0.3.4)
tzinfo (~> 1.1)
arel (6.0.3)
autoprefixer-rails (6.1.2)
arel (6.0.4)
autoprefixer-rails (6.6.0)
execjs
json
bcrypt (3.1.10)
bootstrap-sass (3.3.6)
bcrypt (3.1.11)
bootstrap-sass (3.3.7)
autoprefixer-rails (>= 5.2.1)
sass (>= 3.3.4)
builder (3.2.2)
byebug (8.2.1)
cancancan (1.13.1)
concurrent-ruby (1.0.0)
cancancan (1.15.0)
concurrent-ruby (1.0.4)
daemons (1.2.3)
erubis (2.7.0)
eventmachine (1.0.8)
execjs (2.6.0)
globalid (0.3.6)
execjs (2.7.0)
globalid (0.3.7)
activesupport (>= 4.1.0)
haml (4.0.7)
tilt
......@@ -91,13 +76,15 @@ GEM
json (1.8.3)
loofah (2.0.3)
nokogiri (>= 1.5.9)
mail (2.6.3)
mime-types (>= 1.16, < 3)
mime-types (2.99)
mini_portile2 (2.0.0)
mail (2.6.4)
mime-types (>= 1.16, < 4)
mime-types (3.1)
mime-types-data (~> 3.2015)
mime-types-data (3.2016.0521)
mini_portile2 (2.1.0)
minitest (5.8.3)
nokogiri (1.6.7)
mini_portile2 (~> 2.0.0.rc2)
nokogiri (1.6.8.1)
mini_portile2 (~> 2.1.0)
rack (1.6.4)
rack-test (0.6.3)
rack (>= 1.0)
......@@ -114,11 +101,11 @@ GEM
sprockets-rails
rails-deprecated_sanitizer (1.0.3)
activesupport (>= 4.2.0.alpha)
rails-dom-testing (1.0.7)
rails-dom-testing (1.0.8)
activesupport (>= 4.2.0.beta, < 5.0)
nokogiri (~> 1.6.0)
nokogiri (~> 1.6)
rails-deprecated_sanitizer (>= 1.0.1)
rails-html-sanitizer (1.0.2)
rails-html-sanitizer (1.0.3)
loofah (~> 2.0)
rails-observers (0.1.2)
activemodel (~> 4.0)
......@@ -127,38 +114,38 @@ GEM
activesupport (= 4.2.5)
rake (>= 0.8.7)
thor (>= 0.18.1, < 2.0)
rake (10.4.2)
ruby_parser (3.7.2)
rake (12.0.0)
ruby_parser (3.8.3)
sexp_processor (~> 4.1)
sass (3.4.19)
sass-rails (5.0.4)
railties (>= 4.0.0, < 5.0)
sass (3.4.23)
sass-rails (5.0.6)
railties (>= 4.0.0, < 6)
sass (~> 3.1)
sprockets (>= 2.8, < 4.0)
sprockets-rails (>= 2.0, < 4.0)
tilt (>= 1.1, < 3)
sexp_processor (4.6.0)
simple_form (3.2.0)
actionpack (~> 4.0)
activemodel (~> 4.0)
sexp_processor (4.7.0)
simple_form (3.3.1)
actionpack (> 4, < 5.1)
activemodel (> 4, < 5.1)
spring (1.5.0)
sprockets (3.5.1)
sprockets (3.7.1)
concurrent-ruby (~> 1.0)
rack (> 1, < 3)
sprockets-rails (2.3.3)
actionpack (>= 3.0)
activesupport (>= 3.0)
sprockets (>= 2.8, < 4.0)
sprockets-rails (3.2.0)
actionpack (>= 4.0)
activesupport (>= 4.0)
sprockets (>= 3.0.0)
sqlite3 (1.3.11)
squire (1.3.6)
squire (1.3.7)
activesupport (>= 3.0.0)
thin (1.6.4)
daemons (~> 1.0, >= 1.0.9)
eventmachine (~> 1.0, >= 1.0.4)
rack (~> 1.0)
thor (0.19.1)
thor (0.19.4)
thread_safe (0.3.5)
tilt (2.0.1)
tilt (2.0.5)
tzinfo (1.2.2)
thread_safe (~> 0.1)
......@@ -166,12 +153,20 @@ PLATFORMS
ruby
DEPENDENCIES
activeresource (~> 4.0)
activeresource-response
bcrypt (~> 3.1)
bootstrap-sass (~> 3.3)
byebug
schleuder-web!
cancancan (~> 1.9)
haml-rails (~> 0.9)
rails (~> 4.2)
sass-rails (~> 5.0)
simple_form (~> 3.2)
spring
sqlite3
squire (~> 1.3)
thin
BUNDLED WITH
1.11.2
1.13.6
# encoding: utf-8
Gem::Specification.new do |s|
s.name = "schleuder-web"
s.version = '3.0.0.beta1'
s.authors = %w(paz)
s.email = "schleuder2@nadir.org"
s.homepage = "http://schleuder.nadir.org/"
s.summary = "A web frontend for schleuder."
s.description = "A web frontend to manage schleuder-lists and -subscriptions, usable for admins and users."
s.files = `git ls-files app lib config public etc db/schema.rb README.md Rakefile`.split
s.executables = `git ls-files bin`.split.map {|file| File.basename(file) }
s.platform = Gem::Platform::RUBY
s.require_path = 'lib'
s.rubyforge_project = '[none]'
# TODO: extend/replace expired cert
#s.signing_key = "#{ENV['HOME']}/.gem/schleuder-gem-private_key.pem"
#s.cert_chain = ['gem-public_cert.pem']
s.license = 'GPL-3'
s.add_runtime_dependency 'rails', '~> 4.2'
s.add_runtime_dependency 'bcrypt', '~> 3.1'
s.add_runtime_dependency 'activeresource', '~> 4.0'
s.add_runtime_dependency 'haml-rails', '~> 0.9'
s.add_runtime_dependency 'sass-rails', '~> 5.0'
s.add_runtime_dependency 'bootstrap-sass', '~> 3.3'
s.add_runtime_dependency 'simple_form', '~> 3.2'
s.add_runtime_dependency 'squire', '~> 1.3'
s.add_runtime_dependency 'cancancan', '~> 1.9'
end
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment