Commit 03c59c5d authored by azul's avatar azul

rails: do not require active_storage and action_cable

Need to require all railties separately so we can pick from them.
We are not using the two so better not require them either.

fixes #298.
parent 0d6d7158
......@@ -3,7 +3,16 @@ require_relative '../lib/crabgrass/info.rb'
info 'LOAD FRAMEWORK'
require_relative 'boot'
require 'rails/all'
require 'rails'
require 'active_record/railtie'
# require 'active_storage/engine'
require 'action_controller/railtie'
require 'action_view/railtie'
require 'action_mailer/railtie'
require 'active_job/railtie'
# require 'action_cable/engine'
require 'rails/test_unit/railtie'
require 'sprockets/railtie'
# Require the gems listed in Gemfile, including any gems
# you've limited to :test, :development, or :production.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment