Commit 8f886944 authored by taggart's avatar taggart
Browse files

update dependencies based on current debian package

reorder the lines to match what's in debian/control, to make it
easier to compare in the future. add lines for all debian specified
depends, commented out if we don't yet have an include or know we
don't need it. add some comments.
parent 3301de3d
......@@ -7,37 +7,61 @@ class sympa::debian (
# we just depend on the sympa package which pulls everything in
# these come from the debian package dependencies
# this should move to the generic module soon
# some things in here we don't need, but are there for completeness
# in the generic module
# right now we only include libdbd-mysql-perl, we should figure out a
# better way to deal with that
# other dependencies we don't have: mail-transport-agent, apache,
# sysklogd, lsb-base, adduser,
# other dependencies we don't specify: mail-transport-agent, apache,
# rsyslog, lsb-base, adduser, ca-certificates
# perl related dependencies, in order specified by debian package (to make
# comparing in the future easier
# things that are commented out we don't yet have includes for
include perl::extensions::archive_zip
include perl::extensions::cgi_pm
include perl::extensions::crypt_ciphersaber
include perl::extensions::file_copy_recursive
include perl::extensions::html_format
include perl::extensions::html_stripscripts_parser
include perl::extensions::html_tree
include perl::extensions::intl
include perl::extensions::io_socket_ssl
include perl::extensions::mailtools
#libmsgcat-perl - unsure, something about locale files, only needed at build time?
include perl::extensions::mime_tools
include perl::extensions::net_dns
#libclass-singleton-perl - not currently on whimbrel
#libdatetime-format-mail-perl - not currently on whimbrel
#libfile-nfslock-perl - not currently on whimbrel
include perl::extensions::mail_dkim
#libnet-cidr-perl
#libcrypt-openssl-x509-perl - not currently on whimbrel, needed for S/MIME and SSL
#libcrypt-smime-perl - needed for S/MIME
include perl::extensions::io_stringy
#libnet-ldap-perl - not currently on whimbrel, needed for LDAP
#libcgi-fast-perl - needed for FCGI?
include perl::extensions::intl
include perl::extensions::mime_charset
include perl::extensions::mail_dkim
include perl::extensions::dbd_mysql
include perl::extensions::mailtools
include perl::extensions::mime_encwords
include perl::extensions::mime_lite_html
include perl::extensions::mime_tools
include perl::extensions::net_netmask
include perl::extensions::regexp_common
include perl::extensions::soap_lite
include perl::extensions::template
include perl::extensions::libxml_libxml
include perl::extensions::cgi_pm
include perl::extensions::html_stripscripts_parser
include perl::extensions::html_tree
include perl::extensions::html_format
include perl::extensions::regexp_common
include perl::extensions::fcgi
include perl::extensions::file_copy_recursive
include perl::extensions::net_netmask
include perl::extensions::term_progressbar
include perl::extensions::mime_lite_html
include perl::extensions::unicode_linebreak
include perl::extensions::libxml_libxml
include perl::extensions::soap_lite
include perl::extensions::crypt_ciphersaber
include perl::extensions::io_socket_ssl
# starting in 6.2 we need a bunch of jquery stuff
#fonts-font-awesome
#libjs-jquery (>= 1.11)
#libjs-jquery-migrate-1
#libjs-jquery-ui
#libjs-jquery-placeholder
#libjs-modernizr
#libjs-twitter-bootstrap
# right now we assume mysql, if anyone ever needs a different one we can add support
# also we count on libdbi-perl getting pulled in as a dependency
include perl::extensions::dbd_mysql
package {
'mhonarc':
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment