Commit 73144415 authored by jvoisin's avatar jvoisin

Improves the previous commit thanks to intrigeri

I forgot to add `gi.require_version('Poppler', '0.18')` everywhere,
and `gi.require_version('Gtk', '3.0')` in mat-gui too
parent e51ae6bd
......@@ -25,6 +25,8 @@ logging.basicConfig(level=mat.LOGGING_LEVEL)
# PDF support
pdfSupport = True
try:
import gi
gi.require_version('Poppler', '0.18')
from gi.repository import Poppler
except ImportError:
logging.error('Unable to import Poppler: no PDF support')
......
......@@ -3,6 +3,8 @@
""" Metadata anonymisation toolkit - GUI edition """
import gi
gi.require_version('Gtk', '3.0')
from gi.repository import GObject, Gtk, GLib
from gi.repository import Gdk, GdkPixbuf
......
......@@ -29,6 +29,7 @@ FILE_LIST = zip(clean, dirty)
try: # PDF render processing
import cairo
import gi
gi.require_version('Poppler', '0.18')
from gi.repository import Poppler
import pdfrw
except ImportError:
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment