Verified Commit de0e264b authored by micah's avatar micah

Add npm to bionic Dockerfile.

Because the npm package situation sucks in Debian (its only in
unstable at the moment), we cannot add npm as a Build-Dependency in
the package, so we are adding it to the Dockerfile to make it work.

Once stretch is deprecated, and if Buster gets the npm package,
then this should be put into the Build-Depends of bitmask-dev.
parent b6ef9fe1
Pipeline #15499 passed with stage
in 16 minutes and 2 seconds
......@@ -22,7 +22,10 @@ RUN apt-get update && apt-get -y dist-upgrade -y && apt-get install -y --no-inst
python-setuptools \
debian-archive-keyring \
# add unbuffer and ts for timestamping
moreutils expect tcl8.6
moreutils \
expect \
tcl8.6 \
npm
RUN rm -rf /var/lib/apt/lists/*
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment