Commit fdf1d380 authored by cyberta's avatar cyberta

store provider if vpn certificate was updated correctly

parent d5658c71
......@@ -142,6 +142,7 @@ class EipSetupObserver extends BroadcastReceiver implements VpnStatus.StateListe
case CORRECTLY_UPDATED_INVALID_VPN_CERTIFICATE:
provider = resultData.getParcelable(PROVIDER_KEY);
ProviderObservable.getInstance().updateProvider(provider);
PreferenceHelper.storeProviderInPreferences(preferences, provider);
EipCommand.startVPN(context.getApplicationContext(), true);
break;
default:
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment