CI: Use pylint, instead of pylint3

It seems, despite the name, both packages depend on Python 3. However,
pylint3 seems deprecated, and upstream recommends to install pylint:
https://www.pylint.org/#install

The current versions of both packages in Debian unstable are:
pylint  2.4.4-1
pylint3 2.2.2-1

This commit fixes failing CI jobs due to the use of pylint3 2.2.2-1,
which seems broken.
10 jobs for ci-use-pylint-instead-of-pylint3 in 47 seconds (queued for 2 seconds)
Status Name Job ID Coverage
  Linting
passed linting:bandit #116013

00:00:43

passed linting:codespell #116014

00:00:42

passed linting:mypy #116017

00:00:42

passed linting:pyflakes #116016

00:00:40

failed linting:pylint #116015

00:00:46

 
  Test
skipped tests:archlinux #116018
skipped tests:debian #116019
skipped tests:debian_with_bubblewrap #116020
skipped tests:fedora #116021
skipped tests:gentoo #116022
 
Name Stage Failure
failed
linting:pylint Linting
No job log