diff --git a/CHANGES.rst b/CHANGES.rst
index 6049093c52c4e3622a9e05ffe2d7dab0922eb1e2..705a3f4d8ee8e4bfd114cc4174c574b2736a7825 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -4,6 +4,13 @@ Changes
 0.4 (unreleased)
 ----------------
 
+- Turned former `diceware` module into a Python package. This is to
+  fix `bug #1 Wordlists aren't included during installation
+  <https://github.com/ulif/diceware/issues/1>`_, this time really.
+  Wordlists will from now on be stored inside the `diceware` package.
+  Again many thanks to `conorsch <https://github.com/conorsch>`_ who
+  digged deep into the matter and also came up with a very considerable
+  solution.
 - Use readthedocs theme in docs.
 
 
diff --git a/MANIFEST.in b/MANIFEST.in
index 255218350b9828640250882bce9bfc2e9add63ed..3dd298fe7273258eed1b2242b3ccc14cac138247 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,2 +1,2 @@
-recursive-include wordlists *.txt
+recursive-include diceware/wordlists *.txt
 include README.rst CHANGES.rst LICENSE
diff --git a/diceware.py b/diceware/__init__.py
similarity index 100%
rename from diceware.py
rename to diceware/__init__.py
diff --git a/wordlists/wordlist_en.txt b/diceware/wordlists/wordlist_en.txt
similarity index 100%
rename from wordlists/wordlist_en.txt
rename to diceware/wordlists/wordlist_en.txt
diff --git a/setup.cfg b/setup.cfg
index dd70e163764ae6f9f900711711610b208a8213dc..c22039711e7177cc9497c98d4a4545daa9fe1135 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -6,4 +6,4 @@ docs = develop easy_install diceware[docs]
 [pytest]
 addopts = --doctest-modules
           --doctest-glob='*.rst'
-          tests docs README.rst diceware.py
+          diceware tests docs README.rst
diff --git a/setup.py b/setup.py
index e82ed2cbbfff25a697fd5ef660f93afe1584870d..06778cba60366c2f0fb9cddbfa9ee9e11bfcca28 100644
--- a/setup.py
+++ b/setup.py
@@ -48,8 +48,8 @@ setup(
     license="GPL 3.0",
     keywords="diceware password passphrase",
     url="https://github.com/ulif/diceware/",
-    py_modules=['diceware', ],
-    packages=[],
+    py_modules=[],
+    packages=['diceware', ],
     namespace_packages=[],
     long_description=read('README.rst') + '\n\n\n' + read('CHANGES.rst'),
     classifiers=[
@@ -85,7 +85,4 @@ setup(
             'diceware = diceware:main',
         ]
         },
-    data_files=[
-        ('wordlists', ['wordlists/wordlist_en.txt']),
-        ],
 )